Tornando-se profissional em Blender 3D/Modelando um dado

Origem: Wikilivros, livros abertos por um mundo aberto.
Saltar para a navegação Saltar para a pesquisa
Searchtool.svg Este módulo precisa ser revisado por alguém que conheça o assunto (discuta).


Video Tutorial[editar | editar código-fonte]

Um video tutorial foi criado para atender este capítulo baseado no Blender 2.48a.

Ele esta comprimido no formato de vídeo Theora (.ogg), e para toca-lo, requer um player que seja capaz de decodificar este codec, como o VLC, que pode ser baixado gratuitamente para Windows, Mac, e a maioria dos Linux. O navegador Firefox 3.5 também é capaz de reproduzir vídeos em formato Theora.

Para melhores resultados, recomenda-se que você salve este arquivo no seu computador para reproduzi-lo, ao invés de apenas carrega-lo no seu navegador, considerando que o mesmo esta em 1020 x 746 pixels.

Introdução[editar | editar código-fonte]

No tutorial a seguir, você estará criando um dado. Você vai usar:

  • malha polígono (polygon mesh);
  • loop face de corte (face loop cutting);
  • subdivisão de superfícies (subdivision surfaces);
  • subdivisão de vincos (subdivision creases);
  • bisel (bevel);
  • ajuste de suavização (set smooth);
  • múltiplos materiais (multiple materials);
  • extrusão (extrusion);
  • mesclar os vértices (merge vertices);
  • remoção de duplicados (remove doubles);
  • movimentos combinados (constraints).

Vamos criar os círculos do dado utilizando duas ações: primeiro subdividir e em seguida fazer o dimensionamento manual. Em ambos os casos, começaremos com o cubo padrão.

Primeiro Subdividir[editar | editar código-fonte]

O dado precisa de ter uma matriz 3x3 para os pontos coloridos (pips). Uma maneira rápida de fazer isso é simplesmente subdividir o cubo duas vezes antes de fazer qualquer outra coisa. A desvantagem pode ser que os espaços para os pontos podem não ser exatamente do tamanho que você queria. Se não, veja a próxima seção: Dimensionamento Manual de Pontos.

Dimensionamento Manual dos Pontos[editar | editar código-fonte]

Passo 1[editar | editar código-fonte]

Pressione TAB para entrar em modo de edição e selecione todos as faces para evitar que as normais de face sejam anuladas pelo chanfro das arestas. Pressione W → Bevel, Recursion → 1 (você vai ver o porque posteriormente), em seguida, escolha o tamanho do chanfro (pressione barra de espaço para a entrada manual). Um chanfro (Bevel) de 0,150 estará bom.
Nota: Se você optou por subdividir o dado duas vezes, salte para a secção "Criar Pips" e coloque um chanfro de 0,17 para ter as bordas dos pontos com uma largura de 0,34.

DieAnotherWay2.png

Passo 2[editar | editar código-fonte]

Em EditMode, vá para a aba de edição (F9) e olhe para o Painel Mesh Tools 1 (Mesh Tools More em algumas versões do Blender). Ative o Edge Length (Comprimento da Borda)e anote o comprimento da aresta de cada quadrículo da malha. Este também deve ser de 1,7 caso os ajustes acima foram seguidos.

O botão Comprimento da Borda ("Edge Length") pode não estar disponível na tela; para que você possa acessá-lo talvez seja preciso fechar um outro conjunto de botões.
Ou, você pode usar o BMM para se deslocar até lá para ver o painel Mesh Tools 1 (nas versões mais recentes:: Mesh Tools More) com o botão "Edge Length" nele.
Ou, você pode aproximar e afastar na janela de menu com a tecla CTRL+(NUM+)/(NUM-)


DieAnotherWay3b.png

Passo 3[editar | editar código-fonte]

Um dado típico tem uma grade com 9 possíveis posições para os pontos e para os respectivos espaços entre os pontos. Assim, há convenientemente uma malha com 10 colunas e 10 linhas em cada face do cubo. Cada ponto utiliza o espaço de duas colunas/linhas adjacentes. Como ajustamos a largura da malha para 1.7 , isto significa que cada ponto terá 1.7 x 2 = 3.4, e cada espaço terá 1.7 x 1 = 1.7
9 posiciones.jpg
Muescas y espacios.jpg


Passo 4[editar | editar código-fonte]

BlenderDieanotherway3-00.png

Agora é hora de subdividir a superfície da malha de acordo com a matemática acima. Faremos isso usando "edge loops" - (bordas extras) que você pode adicionar aos objetos existentes.

  • Selecione a vista: NUM1
  • Entre no modo de Loop Cut: CTRL+R (ou KTECLA1 ou KLoop Cut, ou CTRL+ELoop Cut ou CTRL+ENUM5)
  • Selecione o posicionamento dos loops: mova o mouse ao redor da cena até que você veja uma linha roxa indo na direção certa.
  • Digite o número de loops: TECLA9 ( NUM9 ou SCROLL para cima 9 vezes, ou NUM+ repetido 8 vezes);
  • Adicione o loop: BEM (ou Enter, etc) em uma das faces.

Agora só temos de se livrar dos laços de 2º, 5º e 8º loops para abrir espaços para os pontos.

  • Selecione Edge Select ou Vértice Select: CTRL+TAB+NUM2 → (ou CTRL+TABEdges, ou CTRL+TAB+NUM1 → etc.);
  • Desmarque todas as arestas com A;
  • Escolha um loop para remover (usando a tecla B para entrar no modo box selection e desenhe uma caixa sobre o que deseja, o que vai ter todo o loop, por toda a volta do cubo). Você também pode usar Alt+BDM em uma borda para selecionar um loop (ou selecione a borda e clique em Select -> Edge loop).
  • Remova o loop: XEdge Loop.

Mude para as vistas NUM3 e NUM7 e repita os passos conforme o caso. Quando estiver pronto, o seu dado deve ser semelhante à figura à direita.

Criando Pontos[editar | editar código-fonte]

O dado precisaa que lhe sejam acrescentados os pontos. Toda mundo sabe como são os pontos em um dado, certo?

Extrudar e mesclar[editar | editar código-fonte]

Selecione uma das faces, onde poderia ser posto um ponto e extrude: E e ESC. Não clique em nada após teclat o E. Isso realmente substituiria a primeira face por uma outra, embora pareça que nada aconteceu. Mescle a segunda face usando ALT+M para mesclar os 4 cantos no centro. O programa vai informar: Removed 3 vértices. Voce deve obter o seguinte: DieAnotherWay10a.png
Faça isso para a configuração dos pontos desse lado. Portanto, por exemplo, a face 5 do dado ficaria assim:
DieAnotherWay10b.png

Criar Pontos[editar | editar código-fonte]

Selecione uma das arestas do ponto para verificar se o tamanho é 0,34.

Lembre-se que o raio do ponto foi de 0,17. Precisamos usar esse valor para rebaixar a parte central dos pontos. Selecione todos os 5 centros de pontos de uma vez, para economizar tempo ao movê-los para o interior do dado por 0,17. O lado do cubo em que coloquei 5 pontos era a face superior. Assim eu mova os vértices dos pontos para dentro do cubo usando: G, Z, -0.17 e pressione ENTER. Você obterá o seguinte:
DieAnotherWay11b.png

Sem suavização[editar | editar código-fonte]

Pressione TAB para sair do Edit Mode. Se você não tiver feito isso já, clique em Set Smooth no painel de edição e ative a subdivisão de superfícies
Deve ser algo como isto:
200px
200px
Nas versões atuais, você só precisa usar "Add Modifier" na aba Modifiers (no Edit Mode), para adicionar um modificador SubSurf. (Ou pressione SHIFT+O)< br> Na imagem abaixo dos níveis é definido como 3.
DieAnotherWay12c.png

Faça bordas agudas[editar | editar código-fonte]

Em um dado, as bordas dos pontos são geralmente acentuadas, por isso vamos usar vincamento de subsuperfície para dar esse aspecto à borda.

Volte em Edit Mode e com a borda em modo de seleção, selecione todos os perímetros dos pontos assim (desligar o subsurf pode ajudar para o momento):
DieAnotherWay13.png
Pressione SHIFT+E para permitir o vincamento e mova o mouse até o visor informar que o vincamento está ajustado para 1 (para ver o efeito, você deve ter o modificador subsurf ligado). Depois de pressionar SHIFT+E, você pode então definir os valores do vincamento na caixa de informações que você obtém pressionando N enquanto os objetos estiverem selecionados. Isto pode ser útil para verificar se todas as arestas têm o vinco correto, porque o vincamento é calculado por um valor médio e se ele for menor que 1, há uma margem de erro.

Repetição[editar | editar código-fonte]

Repita os passos acima (para extrudar e mesclar, criar pontos e faça bordas agudas) para os outros lados do dado. Lembre-se, o dado é numerado de forma que os lados opostos venham a somar 7. No meu exemplo, significa que eu terei de colocar 2 pontos na face inferior. Quando você terminar, se você ligar Subdiv nível 2, você terá algo parecido com isto:
DieAnotherWay14.png

  • Atalhos do usuário: para fazê-los todos de uma só vez, sem repetição. No entanto, a ordem de operação tem de mudar para fazer funcionar:
    • No modo Face Select, selecione todas as faces de pontos em todos os lados do dado;
    • SHIFT+E para vincar as arestas (precisa ser feito antes da extrusão, pois a extrusão muda a seleção de faces);
    • E -> Individual Faces -> digite -0,17 para a extrusão de todas as faces para dentro do cubo;
    • ALT+M -> Collapse irá reunir todas as extrusões de seus respectivos centros.

Ajustes da Câmera[editar | editar código-fonte]

Você pode fazer um teste de render agora para ver se os pontos estão com tamanhos exatos e que o chanfro está correto. Assim, ajuste o nível de subdivisão para o render no nível 3. Para ajudar a posicionar a câmera tendo o dado no centro da cena, você pode sinalizar o dado adicionando a ele um limitador track-to. Eu prefiro que a câmera rastreie um elemento vazio, porque isto é mais flexível.

Crie um elemento vazio selecionando a vista superior (NUM7) e pressione SPACEAddEmpty. ( Nota: Se você não conseguir encontrar "Empty" na lista, verifique se você está no Object Mode.) É sempre melhor ir em uma das vistas ortográficas, a fim de alinhar novos objetos para os eixos. Se você adicionar algo desalinhado, basta ir ao menu Objeto, em seguida Clear/ApplyClear Rotation (ou ALT+R). Como o elemento vazio foi criado na origem, pode ser que você não seja capaz de visualizar como ele está dentro do dado. Pressione Z para selecionar o Modo Aramado e selecione o vazio. Basta movê-lo fora do cubo até conseguir ajustar o limitador criado.

Para adicionar um limitador track-to, primeiro selecione a câmera, então pressione SHIFT+BDM sobre o elemento vazio, e depois pressione CTRL+T e escolha a opção "Track-to Constraint" na lista. Mova o elemento vazio para dentro do dado. Você pode editar Constraints na aba Object (F7). Adicione um par de lâmpadas (intensidade de ambas ajustada para o nível 1) para obter uma cena como esta ou senta-se livre para experimentar a instalação de iluminação mais avançad.:

Outra forma de posicionar a câmera será selecionaná-la e, em seguida, obter a visão da câmera enquanto movimenta a mesma ao redor do dado. Para selecionar o ponto de vista da câmera pressione NUM0. Use G para movimentar a câmera ao redor da cena e para girar a câmera em torno dos eixos locais pressione R, X, X, para girar no eixo X; R, Y, Y, para girar no eixo Y; e R, Z, Z para girar no eixo Z. Para zoom in e out pressione G, Z, Z e, em seguida, mova o mouse para frente ou para trás. Outra tecla útil a saber é que enquanto você estiver na visão da câmera, pressionando G e BMM, a movimentação da câmera será limitada ao ponto de vista atual. Assim, girar a roda do mouse irá aproximar ou afastar a cena sem, realmente, alterar a posição da câmera.

Você também pode mover a câmera no modo livre "Fly", entrando no modo de visão da câmera (NUM0) e depois Shift+F. Agora você pode "voar" através da cena para ajustar o ângulo da câmera. Certifique-se de usar uma velocidade bem baixa, com a roda do mouse ou as teclas - / + ou a câmera será simplesmente ficará fora de controle.

Render[editar | editar código-fonte]

Para processar a imagem 3D, defina o tamanho da imagem que você deseja. 800x600 é um tamanho decente para ajustar essas configurações: Janela de Botões → aba Scene (F10) → painel Format. No painel Render, certifique-se de 100% esteja selecionado. Se for 50%, o render sairá como 400x300. Para esboços de pré-visualização, não ative OSA, que utiliza o procewsso anti-aliasing, que retarda o processamento de forma significativa. Tente usá-lo apenas para uma renderização final.

Outro ponto importante é definir o formato da imagem. Isto é feito no painel Format. A listagem tem uma série de tipos de imagem. Eu acho que o png é geralmente o melhor, porque não apresenta grandes perdas e oferece a mais elevada compressão entre os formatos sem perdas. Ela também suporta um canal alfa de transparência. Ao renderizar uma animação, é melhor renderizar como uma seqüência de imagens do que como um filme, porque é mais fácil de editar e reparar estes quadros quebrados. Quicktime suporta carregamento de seqüências de imagens e você pode salvar como um filme usando uma ampla gama de formatos de compressão.

Para salvar o render, vá para o FileSalve Rendered Image (ou pressione F3') e digite o nome completo da imagem, incluindo a extensão, por exemplo dado.png.

A saída deve ser algo parecido com isto:
200px
DieAnotherWay15.png

Cor[editar | editar código-fonte]

Vários Materiais[editar | editar código-fonte]

BlenderDieanotherway5-01.png


Vamos precisar de usar múltiplos materiais para aplicar alguma cor, porque um dado típico tem pontos que são de uma cor diferente do dadop em si.

Na Janela de Botões BlenderCommonButtonswindow.png vá para o seletor de painéis Editing BlenderCommonEditing-on.png (F9) novamente e certifique-se que o dado esteja selecionado. No painel Link and Materials há uma seção para Material (o direito, o esquerdo é para Grupo de Vértices) e na caixa da esquerda do ponto de interrogação deve ler "0 Mat 0" (o primeiro número é o número de ligações de materiais para este objeto, o segundo número é o número de ligação do material atualmente selecionado).

DieAnotherWay17.png

O dado pode ter mais do que zero materiais se você já tivesse atribuído materiais para ele. Pressionar o botão New para adicionar 2 materiais no total.

DieAnotherWay17b.png

Pressione o seletor de painéis Shading BlenderCommonShading-on.png (F5).No subpainel Links and Pipelines existe uma caixa MA:Material com o número 2 ao lado. BlenderCommonMaterialbuttons-on.png (botões ciclo de sombreamento usando F5 também). Clique spobre este número e selecione usuário Single no diálogo para fazer os dois materiais que você acabou de criar independentes. Use as setas do lado esquerdo da caixa para trocar os materiais.

BlenderDieanotherway5-04.png

Use o subpainel Material para fazer o material 1 vermelho, simplesmente escolhendo vermelho no seletor de cores (acesso através do retângulo à esquerda do botão Col) ou definindo os controles deslizantes de RGB (à direita do botão Col'). Faça o material 2 branco, fazendo o mesmo. Ou escolha qualquer cor que você preferir.

BlenderDieanotherway5-04a.png

Atribuindo Materiais[editar | editar código-fonte]

Estas cores devem ser atribuídas às partes corretas do dado.

BlenderDieanotherway5-05.png
DieAnotherWay18b.png

Vá emEdit Modee desligue subsurf para tornar mais fácil a seleção. Faça isso no seletor de painéis Editing (F9), subpainel Modifiers. Logo após o modificador subsurf existem três botões. Pressione o mais à direita para desativar o modificador subsurf no modo de edição.

Para tornar o dado vermelho[editar | editar código-fonte]

  • Selecione o dado inteiro (A).
  • Clique no botão de edição (F9).
  • No painel Link and Materials, no lado direito, você verá "2 Mat X" onde X é 1 ou 2. Clique nas setas esquerda/direita até você ver a caixa adjacente ficar vermelha. Assim que você clicar nas setas, verifique que a etiqueta de cima "2 Mat X" mude de "Material" para "Material.001". Estes são os nomes dos materiais que você criou no seletor de painéis Shading (F5) -> Links and Pipeline.
  • Clique no botão Assign (na coluna Material, não na coluna Vertex Grups). Assinale o botão para atribuir o material selecionado à correspondente face.

Agora o dado inteiro deve ser vermelho.

Para fazer pontos brancos[editar | editar código-fonte]

Use o mesmo método acima, mas apenas com as faces internas dos pontos selecionadas e com a cor branca.

Há uma variedade de maneiras para selecionar as faces interiores dos pontos:

Método de Seleção de Pontos 1[editar | editar código-fonte]

Nota: Aqui você pode achar Lasso Select útil.

  • Verifique se você está em Edit Mode BlenderCommonEditmode.png (TAB)
  • Selecione Face Select BlenderCommonFaceselect-on.png: CTRL+TABTECLA3
  • Selecione Limit selection to visibleBlenderCommonLSTV-on.png: deve ser o segundo botão da direita no cabeçalho da 3D View;
  • Vá até o eixo de alinhamento de vista e selecione as faces:
    • Vistas: NUM1, CTRL+NUM1, NUM3, CTRL+NUM3, NUM7, CTRL+NUM7.
    • Para cada vista, selecione a face do ponto com o Lasso Select: segure CTRL e arraste BEM em torno dos vértices dos pontos (não é preciso pressionar SHIFT para adicionar novas seleções, Lasso Select adiciona automaticamente as novas faces à seleção anterior).
  • Se tudo correu bem, você deve ser capaz de ler Fa:84-449 na janela Preferências do usuário, após o número da versão do Blender. (84 = 4*(1+2+3+4+5+6)).

Método Seleção de Pontos 2[editar | editar código-fonte]

Pressione CTRL+ALT+SHIFT+3 e cada face triangular será selecionada. (Todos os pontos mais os 8 cantos do dado . Basta desmarcar o 8 cantos e você está pronto para continuar!). Da mesma forma, você pode selecionar quad faces usando o 4.

Método de Seleção de Pontos 3[editar | editar código-fonte]

DieAnotherWay18.png

Você também pode usar o círculo para selecionar facilmente as faces desejadas. Entre no modo de seleção circular batendo B duas vezes. O círculo pode ser maior ou menor, girando a roda do mouse. Abandone este modo (BDM) para girar o cubo e voltar novamente ao método de seleçao circular, como acima. Os vértices agora selecionados serão automaticamente adicionados aos já selecionados anteriormente, sem a necessidade de manter pressionada a tecla CTRL).


Torne a ativar o subsurf (em Edit Mode → seletor de painéis Editing → painel ModifiersAdd ModifiersSubsurf) e renderizar F12 com OSA (apenas ajustá-lo tão alto quanto o necessário para a resolução de imagem que você está renderizando).

Método de Seleção de Ponto 4[editar | editar código-fonte]

Essa é a maneira mais fácil:
1 - selecione um dos triângulos (a face);
2 - Shift+G, em seguida, escolha Perimiter ou pressione NUM4.

Extra[editar | editar código-fonte]

O motivo pelo qual eu modelei o dado por esse caminho é porque ele também é muito fácil para alterar os tamanhos dos componentes, por exemplo, o bisel e o tamanho dos pontos. Você pode fazer isso escolhendo os segmentos verticais ou horizontais e apenas dimensioná-los em um eixo. Aqui nós vamos reduzir o tamanho do ponto e do bisel pela metade.

Vá para a vista frontal (NUM1), desative o clipping (isto é, permita a seleção de vértices invisíveis) e selecione uma linha contendo pontos (ou seja, Selecione o vertices mode (CTRL+TAB+NUM1), e trace uma caixa vertical de seleçaõ ao redor de uma fina linha de vértices à esquerda de uma coluna de pontos, em seguida, trace uma caixa de seleção ao redor de outra linha de vértices à direita dessa coluna de pontos, perfazendo um total de 64 vértices). Então apenas escale em um eixo, por exemplo, SX0,5. Lembre-se de ter o seu ponto de pivô medio definido como:
200px
Faça isso horizontalmente e verticalmente em torno do dado. Você deve precisar escalar 9 vezes para os pontos e 6 vezes para os chanfros:

200px
Você pode precisar adicionar geometria extra quando você estiver satisfeito com os tamanhos dos pontos e dos chanfros de modo que as bordas do dado não pareçam deformadas devido à subdivisão. Você pode usar o face loop cut novamente,e adicionar linhas extras no meio das falhas dos segmentos.
200px