Tornando-se profissional em Blender 3D/A janela 3D

Origem: Wikilivros, livros abertos por um mundo aberto.
Saltar para a navegação Saltar para a pesquisa


A janela 3D View lhe dá o controle total de como você visualiza o seu mundo 3D. Você passará a maior parte do seu tempo nesta janela, então aqui estão algumas coisas que você deve saber sobre a visão 3D.

Rotacionar[editar | editar código-fonte]

Aqui você será capaz de voar ao redor de sua cena 3D, rotacionando os planos como você desejar. Você verá que o objeto padrão é realmente um cubo, e metade dele se situa acima do plano X/Y, e metade abaixo dele.

Faça o 3D View ativo, colocando o ponteiro do mouse em qualquer lugar dentro dele.

  • Para rotacionar um objeto de forma livre, em qualquer direção, mantenha o BMM pressionado e movimente o mouse;
  • Para rotacionar o plano em torno de um eixo vertical (para os lados), deixando a orientação vertical dos objetos inalterada, pressione CTRL+ALT+SCROLL, ou usando o teclado numérico, NUM4(o 4 do teclado numérico) para girar no sentido anti-horário e NUM6 (o 6 do teclado numérico) para girar no sentido horário;
  • Para rotacionar o plano em torno de um eixo horizontal (para cima e para baixo), deixando a orientação horizontal dos objetos inalterada, pressione simultaneamente Shift+Alt+SCROLL, ou usando o teclado numérico, NUM8 e NUM2.

Da mesma forma, mantendo o mouse sobre uma janela e pressionando NUM2, NUM4, NUM6 e NUM8 a rotação ficará restrita a movimentos de 15 graus, o que pode ser configurado nas preferências do usuário em "View & Controls".

Se você tem sua própria configuração para o BMM do mouse, você deve redefinir esta opção para usá-lo como um verdadeiro botão do meio do mouse (sem clique duplo ou outra coisa). Caso contrário, você deve usar o método alternativo ALT+BEM para o mesmo efeito.

É um cubo! Manter pressionado o BMM é o meio mais rápido e mais fácil de rotacionar a vista e obter uma nova perspectiva de sua cena. Agora você está olhando para o cubo naquele que é conhecido como "modo sólido". Pressionar Z (sim, no seu teclado, a tecla 'Z') irá mudar do modo sólido para o modo aramado. Novo acionamento do Z ira retornar para o modo sólido. Pressionar NUM5 quando NUM LOCK está ativado irá alternar entre as vistas ortográfica e perspectiva (perspectiva parece mais natural). Isso não afeta como o seu produto final irá aparecer, somente a maneira como você vê a cena enquanto você está criando.

Ao se movimentar ao redor da vista, você perceberá os seguintes três objetos:
Câmera, Lâmpada, e Cubo.
Nós iremos entrar em maiores detalhes sobre eles posteriormente.

Ícone do Objeto Nome Descrição
Blender 3D Camera.jpg
Câmera A posição e a rotação da câmera vai determinar o que você verá na hora de renderizar. Para exibir o que a sua câmera está visualizando na janela 3D-View, ative aquela janela pressionando a tecla NUM0. (Lembre-se que a TECLA0, a tecla zero acima das letras, é diferente.) Certifique-se que NUM LOCK está ativada em seu teclado. Para alternar para fora da vista da câmera, arraste o BMM.

Ou pressione NUM0 e SHIFT+F para entrar no "Modo de movimentação de câmera" para posicionar a câmera de forma interativa a partir da janela 3D-View usando o mouse. Pressione BEM para finalizar o posicionamento da câmera.

Blender 3D Lamp.jpg
Lâmpada Uma lâmpada é simplesmente uma fonte de luz. Não será processada, mas a luz que presta à cena será processada.
Blender 3D Cube.jpg
Cubo Este objeto será utilizado. A câmera deve estar apontando para o cubo de forma que você vai vê-lo em tempo de render, se a câmera não está apontando para o cubo, ou se está de alguma forma parcialmente fora do quadro, a imagem vai mostrar isso.
Atalhos de exibições através do NUMPAD

Aqui está uma tabela de combinações simples de teclas que irão resultar em uma visão perfeita.

Combinação de Teclas Visualizar Combinação de Teclas Visualizar
NUM7 Superior CTRL+NUM7 Inferior
NUM1 Frontal CTRL+NUM1 Posterior
NUM3 Lateral direita CTRL+NUM3 Lateral esquerda

O objeto existente na janela de exibição (o objeto que você vê) pode ser alterado para um novo objeto selecionando-o com o BDM e pressionando NUM. (O ponto no teclado numérico) ou NUM, (a tecla vírgula do teclado numérico) em outras configurações de teclado.

NOTA: selecionar um objeto com o BDM só vai funcionar se a sua exibição está definida no Object Mode. Pressione a tecla TAB para alternar entre Edit Mode e Object Mode.

No Blender, existe uma grande diferença entre as teclas numéricas no seu conjunto numérico (teclado numérico à direita) e as teclas numéricas na parte superior do teclado alfa-numérico. Por exemplo, NUM7 refere-se ao número 7 no conjunto numérico, enquanto TECLA7 refere-se À TECLA 7 que está na linha numérica acima das letras.

Se você acidentalmente pressionou TECLA1, TECLA3, ou TECLA7 durante esta etapa e parece que tudo desapareceu, ao invés disso você trocou a camada que estavas a ver. Pressione a TECLA~ (tecla til) para retornar à visualização de todas as camadas, ou pressione a TECLA1 para voltar à visualização da camada 1 que deveria estar originalmente ativa. Da TECLA1 até a TECLA0 (tecla zero) e da ALT+TECLA1 até ALT+TECLA0 são comandos para troca de camadas.

Mover (PAN)[editar | editar código-fonte]

O comando pan significa mover a câmera sobre seu eixo X ou eixo Y. Isso resulta em que o usuário seja capaz de ver mais, ou mais apropriadamente, para ver alguma outra coisa. Pense em um jogo de vídeo de rolagem lateral, como qualquer clássico Mario ou Sonic, no sentido de que seu personagem sempre fica visível na tela, embora dando a ilusão de que está correndo para fora ddela, isto é porque o personagem corre na mesma velocidade que a câmera se movimenta. Isto é evidente face ao movimento contínuo do plano de fundo em relação à posição estática do personagem, demonstrando que a movimentação do personagem e da câmera permanecem relativamente sincronizados.

Para se deslocar na janela de visão do Blender, pressione SHIFT+BMM. Certifique-se de pressionar e segurar a tecla shift antes do BMM, ou a sua 3D View irá girar em seu lugar. Se você tiver uma roda de rolagem no mouse, você pode usar SHIFT+Roda para mover para cima e para baixo, e CTRL+Roda para mover à esquerda e à direita. Se você não tiver uma roda de rolagem ou trackpad ou um BMM (botão do meio do mouse), pressione Shift+Alt+BEM para mover.

Você também tem uma escolha de alternativas de teclado:

          CTRL+NUM8                NUM:        Acima
CTRL+NUM4           CTRL+NUM6          Esquerda      Direita
          CTRL+NUM2                            Abaixo

A movimentação é uma importante habilidade a se dominar; experimente agora.

Aproximar[editar | editar código-fonte]

O Blender oferece várias maneiras de aproximar e afastar a visualização:

  • Se o mouse tiver uma roda de rolagem, girar a roda.
  • CTRL+ALT+BEM e mova o mouse para cima e para baixo (não para a esquerda ou direita)
  • CTRL+BMM e mova o mouse para cima e para baixo (não para a esquerda ou direita)
  • NUM+ e NUM- aproximar e afastar.

Posicionando o cursor 3D[editar | editar código-fonte]

Comentários úteis de um usuário

Eu achei que eu iria selecionar o cubo, quando cliquei nele com o BEM no modo de objeto, com o botão "User 3D transform manipulator" ativado. Para trazê-lo de volta, clique no ícone de mão apontando no cabeçalho da 3D View, ou (Ctrl+Space).

Quando você deseja ter o cursor de volta para o cubo, basta selecionar a câmera com BDM, colocar o cursor no cubo seguindo os passos acima, e selecionar novamente o cubo com BDM.

Eu descobri que isso ajuda muito se você estiver no modo objeto e não no modo de edição. Eu escrevi o seguinte antes de descobrir isto: O problema com este exercício, para mim, é que clicar com o botão esquerdo sobre o cubo seleciona o cubo, ao invés de mover o cursor 3d para dentro dele. Se eu clicar no cubo fora do seu círculo central branco, posso conseguir mover o cursor para lá, mas só para fora deste círculo branco e, mesmo assim, isso só funciona às vezes.

Eu falhei com isso até que eu aproximei o cubo suficiente para perceber este detalhe. Quando estava muito afastado eu selecionava o cubo em vez de criar um ponto de edição.

Eu tive o mesmo problema e descobri que era porque o cubo foi selecionado. Eu me certifiquei que estava no modo de objeto, cliquei com o botão direito na câmera para selecionar a câmera em vez do cubo, e eu poderia, então, posicionar o ponto de edição no cubo . No entanto, isso bagunçou a próxima parte do tutorial, pois você não pode alternar em modo de edição com a câmera selecionada! Talvez a sugestão de tentar colocar o cursor 3D no cubo deva ser descartada, uma vez que levanta muitas dúvidas nesta fase ".

Você pode desmarcar tudo, pressionando A ou o selecionar o botão na visualização em 3D.

O uso do modo aramado funciona melhor para começar com o cursor dentro.

Para obtê-lo de volta no cubo: 1) Verifique se você está no modo de objeto. 2) Selecione o cubo. 3) Clique no menu: Object -> Snap -> Cursor to Selected (o cursor se refere ao cursor 3D aqui), assim ele será colocado exatamente no meio do cubo.

Eu acho que é um ponto essencial observar que, a fim de posicionar o cursor dentro do cubo, o cubo não deve estar selecionado. Pressionar A foi provavelmente a melhor maneira para desmarcar o objeto.

Gostaria de encontrar um comando "desfazer" de grande utilidade ao aprender e experimentar com as várias teclas. Às vezes você faz algo que você não pretendia fazer. Seria bom para desfazer esse efeito indesejado.

O comando "desfazer" existe, mas não parece estar em qualquer menu ou a tecla. Nos Macs você pode desfazer usando Command+TECLAZ, em outros sistemas eu suponho que CTRL+Z fará a mesma coisa.

Se bem me lembro, o histórico do desfazer fica claro quando você alterna entre o modo objeto e o modo de edição.

Você pode definir o número de ações que o comando desfazer pode cancelar, tal como referido nas páginas anteriores.

Perdi muito tempo aqui. Obrigado ao leitor que sugeriu (no cabeçalho da 3D View) Object -> Snap -> Cursor to Selected. Foi a única coisa que funcionou para obter o cursor visível novamente e posicionado no local do clique.

Eu perdi o ponto do exercício pela primeira vez. Você não pode definir um ponto em 3D em uma tela 2D sem técnica. Vistas ortográficas são cruciais. Estou apenas aprendendo, mas já sei, pelo menos, que é preciso ficar atento a elas.

Tal como acontece com um cursor de texto normal (a linha vertical que indica onde o texto que você digita irá aparecer), o cursor 3D é o ponto de inserção de novos objetos. É representado por um círculo vermelho e branco, que indica a localização do seu ponto de edição no ambiente 3D.

Experimente clicar com o BEM no espaço vazio à direita do cubo. O círculo vermelho e branco (o cursor 3D) se move para onde você clicou. Rotacione a visão e observe que o cursor 3D marca um ponto no espaço 3D. "Então, eu posso mover o cursor 3D, mas e se eu quiser colocá-lo de volta em seu lugar original?", você pode estar se perguntando. Para isso, basta pressionar SHIFT+C e o cursor irá saltar de volta à posição anterior.

Em qualquer tela do ambiente 3D, o conjunto de possíveis pontos onde você pode colocar o cursor 3D está determinado e limitado por aquilo que é visível em sua 3D View. Se você fosse mover o cursor 3D novamente, na mesma 3D View, enquanto olha em linha reta para a tela, o cursor poderá ser posicionado a uma distância inespecífica para a frente ou para trás do ponto desejado, independentemente da vista ativa no momento. Isso nos leva a um problema comum a todos os programas de desenho em 3D: "Como é que vamos trabalhar em um ambiente virtual 3D através de uma tela em 2D (o seu monitor)?"

Para ilustrar, tente colocar o cursor 3D no interior da câmera (o objeto em forma de pirâmide), então tente colocar o cursor de volta no cubo, utilizando a mesma vista ativa na 3D View. Provavelmente voce perderá a noção da profundidade em que está o cursor em relação à tela do seu monitor. Fica claro a necessidade de observar a cena de diferentes ângulos para ter certeza da colocação do cursor exatamente dentro do cubo. Se você tentou colocar o cursor de volta no cubo, sem a devida aproximação, involuntariamente selecionou o cubo. Aproveite enquanto o cubo ainda está selecionado, vá para o cabeçalho da 3D View e clique no menu de opções Object -> Snap -> Cursor to Selected, o que irá ajustar o cursor ao cubo que você acabou acidentalmente, selecionando-o. Mas tente o seu melhor movimentando o cursor dentro do cubo usando apenas o mouse, para adquirir experiência.

Você acha isso difícil? Isso é porque, no ambiente 3D, nós precisamos especificar claramente as 3 coordenadas para o posicionamento desejado do cursor. Tente isto: esteja certo de que a visualização em 3D esteja em modo "ortográfico", clicando em View -> Ortographic (ou pressionando NUM5). Pressione NUM7 para obter a vista superior e clique na posição onde deseja colocar o cursor 3D. Isto irá definir 2 coordenadas do cursor precisamente (X e Y), mas que será da terceira coordenada (Z)? Pressione NUM1 para obter a vista frontal e clique novamente no local desejado para posicionar o cursor. Com estes dois cliques, o Blender terá todas as 3 coordenadas da posição do cursor e você terá colocado o cursor com precisão dentro do espaço 3D.

Camadas[editar | editar código-fonte]

Na janela 3D View, tanto em modo de edição como modo objeto, tudo que você criar é atribuído a uma camada visível. Este sistema tem várias utilidades:

  1. Permite divide uma cena em seus diferentes elementos, então você pode colocar o cenário, personagens, partículas e as luzes em diferentes camadas. Eles podem então ser vistos separadamente ou em várias combinações para simplificar a visualização de sua cena.
  2. Quando a renderização for aplicada, apenas as camadas visíveis serão processadas. Você pode usar essa característica para renderizar a cena em partes separadas, para observar a forma como eles parecem.
  3. Luzes podem ser definidas para somente iluminar os objetos que estão na mesma camada em que elas estejam, o que propicia maior controle sobre elas. (Isso também pode ser feito com um agrupamento, mas as camadas são mais rápidas de usar nesta fase).

Para controlar a visibilidade das camadas, as teclas de um teclado alfanumérico irão trocar a visualização das camadas numeradas de 1-9 e 0 (0 é a camada mais à direita, após o 9). Segurando ALT, enquanto usa os números do teclado alfanumérico, você terá acesso à segunda linha de camadas.

Layers grid.png

Como alternativa, existe uma grade de botões no cabeçalho da 3D View que faz a mesma coisa.

Pressionar SHIFT enquanto seleciona uma camada (por teclado ou mouse) irá adicionar esta camada à seleção de camadas visíveis. Você pode usar esse recurso para selecionar as combinações de camadas, ou para desativar camadas individuais de sua atual exibição.

Um objeto que você criar será automaticamente atribuído à camada que você está vendo, se apenas uma está selecionada, ou à última camada adicionada, se voce está trabalhando com uma combinação de camadas. Para mover um objeto selecionado para uma camada diferente, pressione a M e selecione a nova camada no menu que se abrir.

Exercício (espaço 3D em saída 2D)[editar | editar código-fonte]

Siga estes passos simples para ter uma idéia de uma representação do espaço 3D em um dispositivo de saída 2D (tela do monitor):

  1. Mudando para Object Mode usando a opção no cabeçalho da janela 3D View. Ou clique TAB para alternar entre o modo objeto e modo edição.
  2. Desativar a opção "Use 3D transform manipulator" usando o ícone localizado no cabeçalho da 3D View (em forma de uma mão apontando). Ou clicar CTRL+SPACE para alternar.
  3. Clicar NUM7 para mudar para a vista superior. Isso também pode ser realizado através do menu Exibir.
  4. Clique em algum ponto entre o cubo e a câmera usando o BEM.
  5. Escolha um ponto de vista diferente clicando NUM1 (vista frontal), ou NUM3 (vista lateral).
  6. Clique entre o cubo e a câmera com BEM novamente.
  7. Rotacione a vista ao redor para ver como ele se movimentou.

Para a parte onde você está para entrar com o cursor no meio do cubo, basta seguir os passos 3 a 6 novamente. Só que desta vez, você vai, naturalmente, clicar o BEM dentro do cubo, em vez de entre a câmera e o cubo, durante a etapa 4 e etapa 6.

Nota Pelo fato de que estamos trabalhando em um espaço 3D, prescisamos ter duas vistas diferentes do objeto, e que estas vistas se cruzem entre si. Por exemplo, o uso da vista superior e da inferior não seria de muita ajuda para especificar a altura e a profundidade do cursor 3D. Estes pontos de vista também podem ser selecionados através do menu View.

Adicionando e Excluindo Objetos[editar | editar código-fonte]

Verifique se você está em modo objeto. Caso contrário, pressione 'TAB'. (Quando um objeto está selecionado no modo de edição, o TAB alterna para o modo de edição. Se você estiver em outro modo,TAB alterna entre o modo objeto e o modo de edição). A barra de status na parte superior direita da janela de preferências do usuário irá indicar o modo atual, exibindo 'Ob' ou 'Ed', dependendo do modo alternado atualmente. Outra forma de verificar qual o modo que se está ativo é verificar na parte inferior da visualização em 3D.

Object-edit mode.png

Além disso, lembre-se de reativar, a partir da etapa anterior, a 3D Transform Manipulator, se ele ainda estiver desativado,.

Verifique se você tem o cursor no centro do cubo. Consulte a seção anterior (em que o leitor de notas) se você não sabe como fazer isso.

Clique em BDM (CMD+BEM no Mac) sobre o cubo para ter certeza de que está selecionado. Pressione X ou Del para o apagar. Uma janela irá pedir-lhe para apagar objeto. Clique em "Apagar Selecionados" (ou "Erase All").

A razão para ter o cursor no centro do cubo é que nenhum objeto que você criou para a cena estará localizado onde está o cursor .

Para adicionar um objeto, use o menu ADD localizado no menu acima da janela 3D View, ou pressione a Barra de Espaço (Space) para acessar o mesmo menu. Porque não adicionar um macaco? Escolha Add -> Mesh -> Monkey. [Se você preferir que o macaco seja visto frontalmente, certifique-se de estar em vista frontal (NUM1) antes da adição da malha - Nota: no Blender 2.48a, é complicado. Se Blender está em modo objeto, o macaco estará sempre voltado para cima. Se estiver em modo de edição, a direção do macaco dependerá da vista (superior, lateral ou frontal).

Um novo objeto será adicionado, e você estará no que é conhecido como Modo de Edição. Pressione TAB para sair do modo edição, em seguida, TECLAC para centralizar a tela no cursor (onde apareceu o macaco). Pressione a TECLAZ para alternar entre os modos de visão 3D sólido e aramado. Amplie e reduza para um olhar mais atento (SCROLL, NUM, CTRL+BMM ou CTRL+ALT+BEM).

Equipamento fora dos padrões[editar | editar código-fonte]

Tornando-se profissional em Blender 3D/Equipamento fora dos padrões

Mouse sem o BMM[editar | editar código-fonte]

Para simplesmente girar em torno do objeto, habilitar a opção "Emulate 3 Button Mouse" na Views&Controls Preferences e pressione Alt+BEM e arraste.

Tablet PCs[editar | editar código-fonte]

Na 3D Viewport vai conseguir o mesmo efeito do BMM mantendo o ALT pressionado enquanto arrasta sua caneta ao redor da vista.