Panda3D/Manual/Instalação do Panda no Linux

From Wikilivros
Jump to navigation Jump to search

O Processo de instalação - Linux[edit | edit source]

O meio mais facil de instalar o panda é usar os pacotes DEB e RPM. Isso só é possível se sua versão do linux é uma das versões providas do Linux. Se não, você precisará compilar a fonte. Se houver um instalador disponível, baixe e instale o RPM ou DEB apropriados para sua versão do Linux.

Após instalar o panda, você deve rodar os programas de exemplo para verificar se a instalação está perfeita. Para fazê-lo, você precisa mudar o diretório para o de exemplos do panda, selecionar um programa de exemplo, mudar o diretorio para o do programa de exemplo, e rodar o exemplo usando Python.

$ cd /usr/share/panda3d/samples
$ ls
Asteroids
Ball-in-Maze
Boxing-Robots
Carousel
Cartoon-Shader
Chessboard
Disco-Lights
Fireflies
Fractal-Plants
Glow-Filter
GUI
Infinite-Tunnel
Looking-and-Gripping
Media-Player
Motion-Trails
Music-Box
Normal-Mapping
Particles
Procedural-Cube
Roaming-Ralph
Shadows
Solar-System
Teapot-on-TV
Texture-Swapping
$ cd Boxing-Robots
$ python Tut-Boxing-Robots.py

Usar uma versão não suportada de distribuição Linux ou um Python não suportado[edit | edit source]

Pacotes Python precisam ser compilados para uma variante particular do pytohn. Por exemplo, um pacote que funciona no python 2.4 não funcionará no python 2.5. O Pacote que funciona com python 32-bit não funcionará com python 64-bit. O Pacote que funciona com python UCS2 não funcionará com o python UCS4, e assim por diante. Em resumo, o pacote python precisa ser cuidadosamente alinhado, característica á característica ,com um interpretador python particular. O Pacote não funcionará com qualquer outro interpretador python.

Ainda bem que para você, nossas cópias pré-empacotadas do Panda3D já estão cuidadosamente alinhadas. Por exemplo, nosso Panda3D para Ubuntu Gutsy Gibbon já está perfeitamente alinhado com o interpretador python que vem com Ubuntu Gutsy Gibbon. Então, normalmente, você não precisa se preocupar com isso.

Se sua distribuição de Linux não estiver na lista, você precisará compilar sua própria copia do Panda3D. O processo de compilação vai automaticamente criar uma cópia di Panda3D que perfeitamente combine com o interpretador python de sua distribuição do Linux. Isso é fácil de fazer, mas requer uma compilação bem demorada. Por outro lado, é improvável que funcione RPM ou DEB de alguma outra distribuição, devido á necessidade de uma combinação exata caracteristica á caracteristica entre o pacote python (Panda3D) e o interpretador python.

Se você está usando uma cópia do python além da que vem com a distribuição Linux, você vai ter um problema maior. O compilador de scripts automaticamente compila o Panda3D para o sistema nativo do interpretador python, não para outro interpretador python. Para conseguir que o Panda3D compile para outro interpretador python, você terá que editar os scripts de compilação.


Mensagens de Erro[edit | edit source]

O que fazer se você ver essa mensagem de erro (display):[edit | edit source]

display(error): The application requested harware acceleration, but your OpenGL

display(error): driver, GDI Generic, only supports software rendering.

display(error): You need to install a hardware-accelerated OpenGL driver, or,

display(error): if you actually *want* to use a software renderer, then

display(error): alter the hardware/software configuration in your Config.prc file.

display(error): Window wouldn't open; abandoning window.

Esse erro é bem auto-explicativo: Significa que seus drivers de video são inadequados. Obtenha drivers melhores.

O que fazer se você ver essa mensagem de erro (ImportError: No module named):[edit | edit source]

ImportError: No module named direct.directbase.DirectStart

Esse erro significa que ele não conseguiu achar os módulos pytohn -- por favor, tenha certeza de que você está rodando a versão correta do python ( provavelmente python 2.5, isso depende da versão do Panda3D) e que o panda3d.pth esteja localizado dentro do diretorio python site-packages

O que fazer se você ver essa mensagem de erro (Warning):[edit | edit source]

Warning: DirectNotify: category 'Interval' already exists

Esse erro não tem conseguencia. Ignore-o.

O que fazer se você ver essa mensagem de erro (ImportError):[edit | edit source]

ImportError: /usr/lib/panda3d/libpandaexpress.so: undefined symbol: PyUnicodeUCS4_AsWideChar

Isso pode significar que sua ver~sao do python está compilada com a flag Py_UNICODE_SIZE to 2. Por favor procure uma versão python compilada com Py_UNICODE_SIZE configurado para 4 (o padrão normalmente). Veja este Instalação tópico de forum( em inglês ) para uma explicação mais detalhada do problema.