Curso básico de LibreOffice/Formatação condicional

Origem: Wikilivros, livros abertos por um mundo aberto.
Ir para: navegação, pesquisa

Recurso muito útil em uma planilha, a Formatação condicional faz, como o próprio nome sugere, a formatação das células selecionadas de acordo com regras lógicas, estabelecidas pelo usuário. Uma diferença funcional entre o Calc e o Excel é que utilizamos Estilos para formatar condicionalmente no Calc e no Excel, não; isto torna a formatação condicional no Excel mais fácil, mais direta. Porém, se quisermos modificar somente o estilo das células afetadas pela formatação condicional, o Calc é uma mão na roda, pois podemos manipular o estilo de acordo com a nossa vontade e este passará a refletir automaticamente nas células que atendem a este estilo.

Podemos ter uma planilha de notas de alunos onde, por exemplo, as notas iguais ou maiores que 7 (sete) sejam realçadas em amarelo (fundo) com azul escuro na cor da fonte. Primeiro, geraremos a nossa planilha fictícia e injetaremos nela alguns nomes de alunos e suas respectivas notas. Nominaremos esta planilha-exercício como "Planilha.Teste.Form.Cond.ods". Em seguida, invocamos o Estilista (Formatar... Estilos e Formatação, ou pressione F11). Na caixa do Estilista seleciona-se "Estilos de Célula". Na janela do Estilista se dá um clique com o botão de atalho do rato e escolhe-se Novo... Clica-se em Novo e uma caixa de diálogo de formatação surge. Nesta caixa de diálogo é possível definir vários atributos das células afetadas pelo estilo, como a fonte, efeitos da fonte, cor das bordas, formato dos números, etc. Em Nome, na caixa de diálogo, definimos o nome do nosso estilo personalizado. Aqui, damos-lhe o nome "CelAzul".

Nas caixas de combinação Vinculados com e Categoria, deixe como está e mude os atributos da fonte conforme o exemplo. Observe que o Estilista já exibe o nome do nosso estilo personalizado. Definiremos nossa fonte, na caixa de diálogo, como "Nimbus Roman No9 L" ou outra fonte tipo Romana, tamanho 20, negrito; a cor é azul escuro, como se disse, e o plano de fundo é amarelo claro. Confirmamos. Agora aponte para as células a serem afetadas. Selecione-as. Acione o menu Formatar... Formatação condicional. Na caixa de diálogo que aparece é possível definir até 3 (três) condições lógicas. Definiremos apenas uma, pois só nos interessa destacar os aprovados, neste exemplo, por isso habilitaremos apenas a Condição 1. Veja as figuras a seguir:

Ficheiro:Captura da tela de estilos e formatação.png

Ficheiro:Captura da tela de estilos de célula.png

Ficheiro:Captura da tela de formatação condicional.png

Ficheiro:Captura da tela de planilha de testes de formatação condicional.png

O resultado é imediato, como você deve ter percebido. Tente mudar o valor de algum aluno, por exemplo, o sr. "Edival Vulado". Mude-lhe a nota, de cinco, para 7, por exemplo. Veja que o Calc reflete imediatamente a mudança. Brinque um pouco com os números e com as condições.

Esta planilha pode ser melhorada com o acréscimo de uma função nativa da planilha, função Média(). Com esta função nós podemos informar ao software uma série de valores de notas e em uma coluna calcularmos a média das notas. Acrescentaremos mais três colunas à nossa planilha.exemplo: Notas 1, Notas 2 e Notas 3, depois da coluna Média, a qual passará a se chamar "Nota 1". Clique em cima do cabeçalho da coluna Média. Clique com o botão de atalho do rato e escolha, no menu suspenso, "Inserir Coluna", só para testar este recurso. Não necessitaremos dele agora. Clique em Editar → Desfazer ou tecle Ctrl+Z para desfazer este último comando. Às colunas novas daremos rótulos ou nomes condizentes com a nova planilha, na primeira linha da planilha. Onde está escrito "Nota" mudaremos para "Nota 1"; na coluna imediatamente posterior teremos a segunda nota, então teremos em C1 o rótulo "Nota 2"; em D1 teremos o rótulo "Nota 3". Criaremos em E1 um rótulo "Média"; é aqui que iremos colocar a fórmula que permitirá tirar a média das três notas dos alunos, utilizando para isso a fórmula com o mesmo nome e referenciando as três colunas anteriores. Repare que é possível entrar a fórmula manualmente, inserindo o intervalo com a notação Início:Fim (início do intervalo, delimitador (dois pontos), fim); também podemos invocar o Assistente de Funções e fornecer as três colunas das notas como parâmetros dos dados a calcular a média.

Observe que o Assistente de Funções já mostra o resultado, além de sugerir a sintaxe dos comandos. Abra a planilha "broffice.org.curso.plan.teste.format.cond.media.ods" na sua pasta de trabalho ou digite-a, já que é uma planilha bastante pequena. Uma característica importante em planilhas eletrônicas é que nós podemos inserir linhas e colunas conforme nossa necessidade e a planilha ajusta as referências automaticamente; você não precisa reescrever uma fórmula somente por ter inserido um conjunto de linhas ou colunas na sua planilha.

Observe bem a planilha atual. Ela não contém ainda Formatação condicional e as notas estão com valores "quebrados". Haverá uma função que nos permita arredondar estes valores? O que poderíamos fazer para a planilha nos apresentar os dados inteiros e arredondados para cima, como é feito com relação a notas?

Podemos formatar a planilha para dar a esta uma aparência mais profissional? Existe algum recurso como "Auto Formatar"? Se existe, como podemos aplicá-lo à nossa planilha atual?

Veja figura a seguir; ela contém a nossa planilha de teste:

Ficheiro:Captura da tela de planilha de testes de Formatação condicional, ampliada.png

Coloque o foco em E2. Observe que lá já haverá uma fórmula. Esta fórmula usa a função Média. A função Média para esta célula é =média(B2:D2). Como você já sabe, não precisamos reescrever estas fórmulas para as células abaixo. Nós simplesmente as copiaremos, como feito antes, desta vez com o recurso Copiar → Colar. Com o foco (seleção) em E2, utilizaremos os menus de edição e escolheremos Copiar ou acione Ctrl+C. Vá para E3. Com a seta de cursor para baixo e mantendo pressionada qualquer tecla Shift, apontaremos até E10. Repare que todo o intervalo aparece destacado. Com o uso do menu Editar, acione Colar ou simplesmente pressione Ctrl+V. Pronto. Estamos com todas as fórmulas em seus devidos lugares.