Microsoft Office/Macro

Origem: Wikilivros, livros abertos por um mundo aberto.
Saltar para a navegação Saltar para a pesquisa

Uma Macro é uma subrotina que executa uma tarefa.

Macros são utilizadas principalmente para automatizar tarefas repetitivas, mas também podem ser utilizadas para executar tarefas que seriam impraticáveis de serem feitas em modo normal.

Uma diferença conceitual muito importante é que a linguagem de programação normalmente usada pelas macros é Turing completa, enquanto que as planilhas eletrônicas (Excel, por exemplo) não são - por exemplo, não é possível escrever loops com um número indeterminado de passos.

Criação de uma macro[editar | editar código-fonte]

A forma mais simples de criar uma macro é usar o "gravador de macros":

  1. Clicar em "Ferramentas" -> "Macros" -> "Gravar Nova Macro"
  2. Aparece uma janela pop-up de título "Gravar Macro". Pode-se mudar agora o nome da macro (que tem, por default, um nome Macro<n>), ou pode-se deixar como está e mudar o nome mais tarde.
  3. Entrar com os comandos que a macro vai executar
  4. Terminar a gravação da macro
  5. Entrar em "Ferramentas" -> "Macro" -> "Macros"
  6. Aparece uma janela pop-up de título "Macro". Escolher a macro criada e clicar em "Editar"
  7. Examinar e (eventualmente) modificar a macro

Uma macro, criada na forma acima, está na linguagem Visual Basic (ou, mais especificamente, em Visual Basic for Applications).

Não é possível criar diretamente macros em documentos que não tem macros.

Execução de uma macro[editar | editar código-fonte]

Existem várias formas de executar uma macro. A mais simples e direta é através do Menu:

  • Ferramentas -> Macro -> Macros
  • Selecione a macro desejada e clique em "Executar"

Uma outra forma, que é mais difícil de programar mas mais simples de executar, consiste em criar um Botão que, ao ser pressionado, invoca a macro.

Para isto, são necessários os seguintes passos:

  1. Escrever a macro
  2. Inserir o botão no aplicativo (por exemplo, em uma planilha)
  3. Associar o clique do botão à execução da macro

Veremos isto passo a passo.

A escrita da macro foi resumida no parágrafo acima. Para mais detalhes, ver o livro sobre a linguagem Visual Basic.

A inserção do botão é feita de forma não-trivial: em vez do modo natural (que seria "Inserir" -> "Objeto" -> "Botão", ou algum modo parecido), deve-se seguir a sequência:

  1. "Exibir" -> "Barras de Ferramentas" -> "Formulários"
  2. Escolher "Botão" e inserir o botão no documento
  3. Será aberta uma janela pop-up de diálogo que pede o nome da macro. Selecione a macro desejada
  4. Pode-se o nome exibido pelo botão para indicar o que ele vai fazer, alterando o campo no próprio botão

Algumas operações são possíveis no "modo de desenho" e outras no "modo de execução". É possível sair do modo de desenho entrando com "Exibir" -> "Barras de Ferramentas" -> "Sair do modo de desenho" .

Principais variáveis[editar | editar código-fonte]

  • Documents
  • Selection
  • Worksheets ou Sheets
  • Range, Rows, etc

Ver também[editar | editar código-fonte]